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GeoGebra is free and multi-platform educational dynamic mathematics software that
joins geometry, algebra, and calculus in an easy to use package.

On the one hand, you can create constructions with the mouse by using a variety of
construction tools to create points, vectors, segments, lines, and conic sections. On the
other hand, you may directly input algebraic expressions and functions by using a syntax
that is based on school-notation (e.g., g: 3x + 4y = 7 to enter a linear equation, or
c: (x— 2)?+ (y— 3)% = 25 to enter a circle).

The most remarkable feature of GeoGebra is the dual representation of mathematical
objects: every expression in the algebra view corresponds to an object in the graphics
view and vice versa. No matter how you created these objects in GeoGebra, you can
easily modify them using the mouse or additional keyboard input. In addition, a range of
commands are available that allow you to create new objects or modify existing ones
(e.g., Centroid, Derivative, Extremum, Perimeter).
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After starting GeoGebra, you will see the window shown above. Using construction tools
in the toolbar you can create constructions in the graphics view by using the mouse. At
the same time, the corresponding coordinates and equations are displayed in the alge-
bra view. The input bar is used to enter coordinates, equations, commands, and func-
tions directly, which are displayed in both, the algebra and the graphics view immediate-
ly after pressing the Enter-key. In addition, GeoGebra provides Undo/Redo buttons as
well as lists of Input Options in order to make it easier for you to correct mistakes and
enter expressions using the keyboard.
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This GeoGebra Quickstart document is meant to facilitate your first contact with the
software by guiding you through the following three examples. We recommend for you to
work through the instructions and also try out the given tips and tricks.

Example 1: Circumcircle of a Triangle
Example 2: Tangents to a Circle
Example 3: Derivative and Slope Function

Please familiarize yourself with the interface of GeoGebra before you actually start your
first construction:

e Open the Toolboxes: Click on the small arrow in the lower right corner of the
icon of any construction tool to open the corresponding toolbox. It contains a se-
lection of similar tools (e.g., point tools, transformation tools).

e Toolbar Help: Select different construction tools and read their toolbar help. It
gives you the name of the activated tool and explains how to actually use it.

e Visibility of Algebra View and Input Bar: Algebra view and input bar can be
hidden or shown using the View menu. Just check or uncheck the corresponding
menu item to change the visibility status of these interface components.

e Undo/Redo Buttons and Input Options: Make sure you know where to find
them and to use them in order to facilitate using GeoGebra.

Example 1: Circumcircle of a Triangle

Task: Draw a triangle A, B, C and construct its circumcircle using the construction tools
as well as commands.
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Construction Using the Mouse

Hide the algebra view and input bar. In the Options menu, set the ‘Labeling’
option to ‘New points only’.

Select tool Polygon from the toolbar. Click in the graphics view three times to
create the vertices A, B, and C. Close the triangle by clicking on point A again.

Hint: Select tool Move and drag the points or their labels to change their posi-
tion in the graphics view.

Select tool Line bisector from the corresponding toolbox. Construct two line
bisectors by clicking on two sides of the triangle.

Select tool Intersect two objects and click on the intersection of both line bi-
sectors. This will create the intersection point D which is the center of your
triangle’s circumcircle.

Rename this intersection point to ‘M’: Select tool Move and click on the inter-
section point. When it is highlighted, type the upper case letter ‘M’ in order to
open the ‘Rename’ dialog window. Click button ‘Apply’ to apply the name
change.

Select tool Circle with center through point. Click first on the center point M
and then on any vertex of the triangle to create the circumcircle.

Drag test: Select tool Move and use the mouse to change the position of any
of the vertices. If you did the construction correctly, the circumcircle of the tri-
angle will always run through all three of its vertices.

Tips and Tricks

Show/hide objects: To hide an object, right click on it (Mac OS: Cirl-click) and un-
check ‘Show object’. To show an object again, you can either right click (Mac OS:
Ctri-click) on it in the algebra view or use the Properties dialog (see next tip).
Properties dialog: The appearance of objects (e.g., color, line style) can be
changed easily in the Properties dialog: Use the right mouse button (Mac OS:
Ctri-click) again to click on the object and choose ‘Properties’ from the appearing
context menu.

Position of graphics view: In order to change the position of the graphics view,
choose the tool % Move drawing pad and use the mouse to drag the graphics
view.

Construction protocol: You can open the construction protocol using the View
menu. It provides a table listing all the steps you took while doing your construc-
tion. The construction protocol allows you to redo your construction step by step
by the use of the arrow keys, or to modify the order of various construction steps

GeoGebra Quickstart — December 2008 4



(see the Help menu of the construction protocol). In addition, you are able to hide
or show different columns of the construction protocol using the View menu of the
construction protocol window.

e More information: You can find more information about constructions by mouse in
the GeoGebra Help document (menu Help, or online atwww.geogebra.org/help|-
section ‘Geometric input’).

Construction Using the Input Bar

You can now repeat this construction of a triangle’s circumcircle by using the input bar
instead of the mouse. Open a new graphics view by selecting ‘New’ from the File menu.

Hint: You might want to save your construction before you open a new window.

Show the input bar at the bottom of the GeoGebra window (menu View). Type the fol-
lowing commands into the input bar and press the Enter-key after every line.

(2, 1)
(12, 5)
= (8, 11)
int: You have just created the three vertices for your triangle.

T O W »

Polygon[A, B, C]

1 a = LineBisector(a]

1 b = LineBisector([b]

Hint: Objects a and b are sides of triangle ABC. Input 1 _a creates an index a for
object / which is shown as |, on screen.

M = Intersect[l a, 1 D]
Circle[M, A]
Hint: Input M = names the intersection point M.

Tips and Tricks

e Automatic completion of commands: After entering the first two letters of a com-
mand, GeoGebra tries to complete it automatically. If you want to adopt the sug-
gestion, press the Enter-key, otherwise just continue typing.

e List of commands: The input options at the bottom of the GeoGebra window pro-
vide a list of all available commands. Therefore, you don’t need to type in every
command, but you can also select it from the provided list instead.

e Input icon: Clicking at the icon ‘Input’ at the bottom left activates the mode ‘Input
bar’. In this mode, you can click on any object in the algebra or graphics view to
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copy its name into the input bar. For more tips concerning the input bar click on
the question mark in the bottom left corner of the GeoGebra window.
e Combination of input forms: You will obtain especially good results from your work

with GeoGebra by combining the advantages of both input forms, mouse and in-
put bar.

Example 2: Tangents to a Circle

Task: Draw circle c: (x - 3)* + (y - 2)> = 25 and construct its tangents through point
A=(11,4).
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Construction Using Input Bar and Mouse

Type the equationc: (x - 3)2 + (y - 2)2 = 25 into the input bar and
press the Enter-key to create circle c.
Hint: Exponents can be found in the left most input options list.

Use tools ®& Zoom in and &\ Zoom out (or the mouse wheel) as well as tool
+ Move drawing pad to adjust the graphics view if the circle doesn't fit into the
graphics view.

Enter command C = Center[c] into the input bar.
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Create point A by typing in A

(11,

Select tool Tangents and click on point A and circle c.

4) or using tool New point.

Select tool Move and drag point A with the mouse to observe the movement of

view.

Tips and Tricks

the tangents. Also, try to drag circle ¢ and examine its equation in the algebra

e Modifying equations: After selecting tool % Move, you can modify the equation of
the circle directly in the algebra view. Just double click the equation and make
your changes in the appearing editing field. Press the Enter-key to apply your

modifications.

e More information: You can find further information about the possibilities of the in-

put bar in the GeoGebra Help document
www.geogebra.org/help|- section ‘Algebraic input’).

Example 3: Derivative and Slope Function

(menu Help,

or online at

Task: Create function f(x) = sin(x) and construct its tangent to a point on the function

graph in order to construct the slope function or derivative.

L@ A= (2.32, 0.73) 4

@ f(x) = sin(x)

. Dependent objects
@ B =(2.32, -0.68)
@ f(x) = cos(x)

@ 5=-0.68

L@ty = -0.68X + 2,21
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Version 1: Point on Function

&

@)

&

Enter function £ (x) = sin (x) into the input bar and press the Enter-key.

Select tool New point and click on the function graph. This creates a point A
on the function graph.

Hint: Wait for the function graph to be highlighted before you click to create
the point.

Select tool Move and drag point A with the mouse to check if it was created
correctly: the point needs to be restricted to move along the function graph.

Select tool Tangents. Click on point A and function f.

Change the tangent’s name to t. Select tool Move and click on the tangent.
Type in ‘t’ to open the ‘Rename’ dialog window and click the ‘Apply’ button.

Enter command s = Slope([t]
Hint: This calculates the tangent’s slope and draws its slope triangle.

Select tool Move and drag point A with the mouse to examine the movement
of tangent t.

EnterB = (x(2), s) tocreate a point B that has the same x-coordinate as
point A and the slope of the tangent as its y-coordinate.
Hint: x (4) gives you the x-coordinate of point A.

Turn on the frace of point B: Click on point B with the right mouse button (Mac
OS: Ctrl-click) and select ‘Trace on’ from the appearing context menu.

Select tool Move and drag A with the mouse. Point B will leave a trace that
draws the slope function or derivative of function f.

Check your construction: Type the command Derivative [f] into the input
bar. Check if the trace of point B exactly matches the graph of the derivative.

Tips and Tricks

Change the function’s equation: Enter a different function into the input bar (e. g.
f(x) = x* - 2x?)to overwrite the initial function f. Note that your construction
immediately adapts to this change.

Dragging a function graph: Select tool * Move and drag the function graph with
the mouse. Observe the changing equations of the function and its derivative.
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Version 2: Pointat x =a

You are now going to create another version of the last construction. Open a new Geo-
Gebra window by selecting ‘New’ from the File menu. Type the following commands into
the input bar and press the Enter-key after every line.

(x) = sin(x)

T o rh
I

2
: Number a is not displayed in the graphics view by default.

—

in

(a, £(a))
: This creates a point T on the function graph with x-coordinate a.

T4
5
—

= Tangentla, £f]
: This creates a tangent to function f at position a.

T
5

Slope[t]
(a, s)
int: This creates a point B with x-coordinate a and slope s as a y-coordinate.

ITTon
Il

Derivative[f]
Change the value of number a in one of the following ways:

e Arrow keys: Select tool * Move and click on number a in the algebra view. You
can now change the value of number a by pressing the arrow keys on your key-
board. At the same time, point T and tangent t will move along the function graph.

e Sliders: You can also change the value of number a by using a slider: right-click
(Mac OS: ctrl-click) on number a in the algebra view and select ‘Show object’
from the appearing context menu. You are now able to drag the point of the slider
with the mouse to change the value of number a.

Note: Numbers are displayed as sliders in the graphics view of GeoGebra.

Tip: Sliders and also the arrow keys can be very useful to examine parameters of equa-
tions, for example the parameters p and q in the quadratic equation y = x2+p x +q.

Version 3: Tangent in Parametric Form

GeoGebra is able to deal with vectors and also parametrical representations of lines.

Therefore, it is possible to construct a tangent t without using tool 42 Tangents or com-
mand Tangent]].

Remove the tangent from your last construction: Click on the tangent with the

right mouse button (Mac OS: Ctrl-click) and select i/~ ‘Delete’ from the appearing
context menu.
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Enter the following commands into the input bar to create a vector v and tangent ¢
in parametric form:

(L, £'(a))
: £' (a) gives you the derivative of function f.

—~

v
Hin
t: X =T+ r v

Hint: Vector v is the direction vector of tangent t. Instead of parameter r you could
also use any other letter that is not used in your construction as a parameter.

Tips and Tricks

e Tangent with direction vector: There is an additional possibility to construct the
tangent by using the direction vector v and command Line: t = Line[T, V]

e More information: You can find further information about the commands of Geo-
Gebra in the GeoGebra Help document (menu Help, or online at
[www.geogebra.org/help| - sections ‘Algebraic input’, ‘Commands’). You can also
download the GeoGebra Help document as a pdf-file atjwww.geogebra.org/help

Further Information

Please visit GeoGebra’s homepage [www.geogebra.org|to find more information as well
as the most recent version of GeoGebra.

GeoGebra also allows you to easily create interactive web pages, so called dynamic
worksheets, that can be used with every Internet browser (e.g., Firefox, Safari, Internet
Explorer). You can find examples and additional information on GeoGebra’s web page.

GeoGebra Homepage www.geogebra.org

GeoGebra User Forum www.geogebra.org/forum

GeoGebraWiki - pool of educational materials |www.geogebra.org/en/wiki
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